Hjælp til Pi som infoskærm

Raspberry Pi Shop Forums Generel snak Hjælp til Pi som infoskærm

Viewing 2 reply threads
  • Author
    Posts
    • #14611
      NielsM
      Member

      Hej alle,
      Jeg er stødt på problemer som jeg ikke selv kan finde en logisk/teknisk forklaring på.

      Jeg har påtaget mig den opgave, at sætte en række Pi-computere op som infoskærme, men jeg synes jeg er endt i en blindgyde. Jeg har installeret Chromium og opsat ‘Kiosk mode’ til at starte i fuldskærm ved boot og den går selv ind på et bestemt link. Jeg har slået pauseskærm, inaktivitet, fejlmeddelelser osv. fra.

      Jeg skal levere dem, så de (kunden) ikke selv skal foretage sig noget udover at sætte HDMI og strøm til. Jeg har derfor tilføjet hver deres wifi-indstillinger ind i wpa_supplicant.conf og testet at den logger på deres net.

      Mit problem! Visse af dem booter fint og kører upåklageligt i noget tid andre booter til sort skærm. Enkelte af dem der først har bootet og kørt upåklageligt begynder også at boote til sort skærm.
      Jeg kan herefter trykke ALT+F2 og logge ind via sudo startx, men her kan jeg jo ikke foretage mig noget – kun konstatere at der er gået noget galt under boot.

      Kan I gennemskue problemet?
      Hvad skal I bruge af information for at hjælpe med at diagnosticere?
      Er en Pi/SD-kort som hukommelse bare ikke mere stabil og må derfor droppe projektet?

      Det er Raspberry Pi 2 Model B med Raspbian installeret.

      Det skal tilføjes, at jeg er ret grøn i alt dette kodning og mine ‘kompetencer’ er kommet af ‘How-To’s’ på nettet kombineret med en god portion stædighed!

      Jeg håber I kan hjælpe
      På forhånd TAK!
      – Niels

    • #14621
      osj
      Member

      Hej
      Hvad for en vejledning har du fulgt?

      Åbner du konsolden med ALT+F2, logger du på med
      brugernavn “pi”
      password “respberry”

      Derefter kan du stoppe x-serveren med
      sudo init 2
      eller starte den med
      sudo init 3

      X-serneren kører på ALT+F7

      Hvad køres der på info-skærmene
      tekst
      billeder
      flash eller
      film

      Måske skal du slå log-filerne til, så du kan se hvad der sker.

      Mc og htop er gode værktøjer, til fejlfinding.

      osj

    • #14667
      NielsM
      Member

      Tak for svar.

      Jeg har nu rodet videre med det, men ingenting hjalp – lige indtil jeg prøvede med et andet SD-kort. Jeg har nu skiftet alle SD-kortene ud og det var roden til problemet. 🙂

Viewing 2 reply threads
  • You must be logged in to reply to this topic.